Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
EBLink Debugger Problems

currently i'm having some trouble with EBLink and debugging a nucleo board. (I tried with latest st-link fw and V2.J34.M25; I'm also using latest eblink 4.0.6)

When i try to connect, i get an network error

When i change from port 4242 to 4244 (just tried this one number), i can connect and my application runs.

But if i do anything in EB (Setting breakpoint, halting application etc), eblink crashes. (Error: Connection with target lost)
Exception condition detected on fd 580
Debugger finished with status 1

This is most likely an OS problem. Check your ports which are already opened for listening by other applications.

I never had those errors, ever. Currently I'm working on new EBlink release which supports multiple core CPU's (like stm32H755) so there are multiple TCP servers active (for the stm32h755 two, one for every cpu) and still no problems with sockets.
I could solve the port problem, but the debugger is still crashing  Sad

I updated all drivers and tried different usb ports. Im using Win10x64 20H2.

If you google on "Exception condition detected on fd" then you will find a lot of issue reports with all kind of debug probes like, OpenOCD, Jlink, P&E etc.

That's explainable because we all use, more or less, the same network socket algorithms.

Is this for all your projects or is it project related?


My Win10 version is currently 21H1 so that shouldn't be the problem.

Forum Jump:

Users browsing this thread: 1 Guest(s)