Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Single stepping STM32F091
#1
I have several STM32 CubeMX / HAL projects and I use EmBitz as IDE. All porjects working fine, including compilation and debugging. There are projects with STM32F103, STM32F205, STM32F207, STM32F405, STM32F429, STM32L476, etc. There is one exception: Execution single stepping is not working with STM32F091 target. Always steps into timer interrupt and never get out. Is there a solution? Thanks.
Reply
#2
This is an official STM32F091RC Nucleo board.
This is a CubeMX generated HAL project. There is FreeRTOS and TIM2 is the time base.
I tried to put DBGMCU->APB1FZ |= DBGMCU_APB1_FZ_DBG_TIM2_STOP; at several places: the beginning and the end of init in main(), and into the start of the default task. No luck. Single stepping is iterating over and over here in function void TIM2_IRQHandler(void) in stm32f0xx_it.c.
If I manually stop execution, or it hits a breakpoint anywhere, it stops. OK. Then I click single step (go to next line) and the debugger jumps into TIM2_IRQHandler instead of next line. I tried to click on step out, but it stopped again in TIM2_IRQHandler.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)