Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Adapting STM32CubeMX Projects for EmBitz
#21
Just a few minutes to convert it manually. Of course the promised import function is nicer.
Reply
#22
(31-10-2016, 04:55 AM)OliviliK Wrote: I am planning to leverage the bits that STM has developed and stored in the SW4STM32 folders (System Workbench for STM32).  I have not yet done the automation.  The manual steps are described in the attached document.


Using a fresh install of emBitz release 1.11, SDK v1.1 (December 8, 2016), I tried following the steps in the text file you attached, but came across a few problems in step 6.
Quote:6. Open EmBitz and create a new empty project
- File menu, select New. select Project..., select Empty, select Go
- Enter Project title, such as F7_GPIO_IOToggle
          select Next, select Finish
- Debug menu, select Plugins, select SVD repository,
          select STmicro, select STM32F7x, select OK, select Run to main(), select OK
- Debug menu, select Interfaces, select Run to main()
- Open GDB server menu, configure the interface for used method, such as ST-link
- File menu, select Save project
- File menu, select Close project
  1. I entered a project name, but the "Folder to create project in" did not get populated, so I had to enter a workspace directory path as well.  It seems emBitz does not create a default workspace directory, and the empty project wizard does not use a default workspace root directory path.  I had to manually create a workspace directory and enter it explicitly in the project directory field of that dialog.  (I do see that, once a directory name has been entered in that location, it becomes the default for the next new project wizard).
  2. When I opened the dialog at Debug/Plugins/SVD repository, the Membership settings dialog appeared.  I've just downloaded emBitz; I'm not ready to drop the USD equivalent of 49 Euros just to try my first project.  It looks like a non-member has no access to any plugins, scripts, or svd files beyond what is included in the emBitz install itself.  The result is that I cannot select STM32F7x, select OK, or select run to main().
The lack of a way to get a system view description (SVD) file for the target would appear to make the rest of what otherwise looks like a good way to gets started, unworkable.  I also tried using the new STM32 project wizard, hoping it would get around the SVD file problem, but it does not.  I also note that not only does emBitz not know about the STM32F7 family, it doesn't recognize the STM32L4 MCU family, either.  I suppose, if I had some examples, I could write my own SVD files; I'll look around.
The 1.2 release, which was "a few weeks away" back at the end of 2016 has not been announced as of 9/17/2017.  The current release (1.11 with sdk v1.1) is what I'm using.  I assume that "1.2" referred to the sdk version, not the emBitz release.
I'm not asking you to fix this, just letting you know my experience.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)