Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
EmBitz 0.42 and 1.11, issues with command line compilation
#1
(UPD 2018-10-08. Original issue was reported for version 0.43, but as of today the issue can be reproduced on version 1.11, so I've updated the title)

First of all I'd like to thank for a great product, which helped me a lot and works great in most of usage scenarios.

I'm trying to setup one of my .ebp projects on the build server (Jenkins). So basically I need to be able to compile it using command line. When I do so (embitz.exe project.ebp --build --target="Release") I get build log window (which I did not expect to see) and it closes after compilation is complete. But if I do --rebuild or --clean and then ---build after that then I get "The build is in progress. Are you sure you want to abort it?" modal dialog after compilation is completed and before Build Log window is closed: [Image: 06518-2c988e9b-7d56-448a-b6cf-685d45805168.png]

This is unacceptable for build server as it would hang without user reaction on that dialog box. So is there a way to avoid this modal dialog?


To summarize:
1. I think that during batch compilation there should be no UI (not even Build Log window), output should go to either standard output or redirected to file. Results should be either in the log or return codes. Or at least there should be a command line option to disable all UI
2. Looks like the issue is that EmBitz itself tries to close Build Log window slightly too soon, so if there is additional delay introduced then Build Log windows would be able to close properly without showing modal dialog. (I get the same modal dialog if I try to close Build Log window manually before compilation is complete).
Reply
#2
Ok, we have to fix this.

Quote:Or at least there should be a command line option to disable all UI
Yes, I totally agree

I'm busy with a next release and I will try to fix as much open tickets as possible, I will also open a ticket for this issue.

Regards
Gerard
Reply
#3
Thank you very much. Maybe you know of any workaround before fix is available? The only one that I can think of is killing the process after some timeout, but that is not very ellegant
Reply
#4
Hi,

I have solved your problem bit I don't have a workaround.

I could build a special compiler plugin for you without that blocking message window but I need to build a totally new version to remove that batch log window.

-Gerard
Reply
#5
Thanks, it works great!


Just a heads-up regarding headless execution: Jenkins (and I believe other CI solutions as well) run as Local System account by default, so when it launches EmBitz for batch build EmBitz thinks that it's a first launch by this user (Local System) and displays some greeting modal window (definitely "default compilers", maybe also 1 or 2 more, I don't remember). If user doesn't acknowledge this window then it is shown again on every following launch preventing build to execute properly. But apparently user cannot see this window in his own UI session. The workaround is to launch EmBitz once from Local System account (using PSTools for example) and make initial configuration (acknowledge default compilers, configure html build log). Another workaround is to create a dedicated user, initialize EmBitz for this user and run CI server using this account.


So now I have my build server running CI builds with EmBitz!
Reply
#6
Hi again. We've switched to EmBitz 1.11 and seems like it has the same issue with build log pop-up for unattended builds again, the same as 0.42. The version 0.43 did not have the issue, but seems like the fix was not included into 1.11.

Is it possible to have it included into 1.11?
Reply
#7
I don't know what you mean, screenshot?
Reply
#8
Same problem. Version 1.11 Dec 8 2016 18:00:09
   
Reply
#9
Yes, this issue is known and fixed for upcoming releases
Reply
#10
When will this fix be available?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)