EMbitz
EBLink Support for STMF303K8 - Printable Version

+- EMbitz (https://www.embitz.org/forum)
+-- Forum: EBlink (https://www.embitz.org/forum/forum-3.html)
+--- Forum: Bug report (https://www.embitz.org/forum/forum-9.html)
+--- Thread: EBLink Support for STMF303K8 (/thread-19.html)

Pages: 1 2


EBLink Support for STMF303K8 - vdaniel - 01-10-2020

When I try to start debugging with the Eblink3.1.0, I receive an error message:

Incompatible EBlink version 2.0
Please update

The previous 3.0.3 and 3.0.4 did not support the STMF303K8, but without this message.

vdaniel


RE: EBLink Support for STMF303K8 - vdaniel - 01-10-2020

The same error was with the STM32G031. The EBlink 3.0.4 works fine.


RE: EBLink Support for STMF303K8 - vdaniel - 02-10-2020

With the EBlink 3.2.0 the same error

vdaniel


RE: EBLink Support for STMF303K8 - Mink - 03-10-2020

Check with this file (for G0).
Unzip to folder scripts\stmicro\


RE: EBLink Support for STMF303K8 - vdaniel - 03-10-2020

Hi Mink,

Thank you, but it does not help. With you new script and 3.2.0 nothing changed:
Incompatible EBlink version 2.0
Please update


vdaniel


RE: EBLink Support for STMF303K8 - vdaniel - 05-10-2020

With the 3.3.0 the same message.
For me the only working is 3.0.4.

vdaniel

Dear All, I am sorry, I understand, that do something wrong.
I thought, that EBlinkInstaller3.x.x.exe automaticall installs
all necessary files.
But I can see the EBlink in "Debug interface options" only after installing the
the "share" folder from Mink.
Maybe this files interfere?
Please, can "embitz" or sombody (maybe Mink) of forum members write an exact
instruction how to use the new EBlink version.
Great thanks in advance.
vdaniel


RE: EBLink Support for STMF303K8 - Mink - 05-10-2020

The errors in stm32gx.script that I fixed are still present in the new version (3.3.0). It's strange. Isn't EmBitz reading this thread?


RE: EBLink Support for STMF303K8 - vdaniel - 05-10-2020

Hi Mink,

First of all great thanks to you for moving the embitz project
from stalling point.
Your first instructions were very clear and easy to follow.

Maybe you can consider a case, when one install EmBitz 1.11
from scratch, tnen instal EBLink 3.3.0.
I tried. In the Debuf interface options\Select interface there
is no EBlink.

How I cam tie the new installe EBlink to new installed EmBitz?

vdaniel


How it is possible to merge both.


RE: EBLink Support for STMF303K8 - Mink - 05-10-2020

I am not using EBlink installer.
I copy eblink.exe and folder scripts with github, in folder C:\Program Files (x86)\EmBitz\1.11\share\EBlink\
If EBlink is located in a different folder, need to specify the path in the window "Debug interface options", in tab "GDB Server".


RE: EBLink Support for STMF303K8 - vdaniel - 05-10-2020

Hi Mink,

Thank you very much.  I will try tomorrow.

vdaniel