Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Burning flash and debugging for EFM32G222 and J-Link
#1
Hello,
I'm using EmBitz for some years already and is very satisfied with this IDE. I've already successfully worked with different families of MCUs (STM32F1/F4, Nordic nRF51822, Atmel ATSAMC21) and haven't had any problems with debugging and flashing controllers with ST-Link or J-link.
But now I want to start with EFM32 Gecko family from SiLabs and have a lot of problems with flashing these chips. I can actually flash them outside of EmBitz (with the native tool from Segger) and then everything is working, I can debug my firmware with EmBitz. But it seems not to be possible to flash chips with the EmBitz script. I have taken a look at the script, it seems to be the same script as the one for NXP, I've not found any serious differences. But it doesn't work. It can't enter the programming mode but is able to debug the chip. I have tried to change some settings but without any success.
May be somebody has solved this problem?
With best regards, Alex
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)