Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
debug without real board
Good day Guys!

Big respect to  EMBITZ. Found EMBITZ IDE useful in many aspects. I work under XP.

Unfortunately, I'm still away from civilization and the board is still on the way. I would not want to lose the time and start debugging.

Maybe my question is strange, then do not be offended. Whether debugging is possible on the principle of simulation in the debugger. Just as it was in MPLAB MPLABSIM?
You need a target processor simulator and an EmBitz-compatible debugging tool (GDB server) that can connect to the simulator. None of them are included in EmBitz.
So pity.
Hi guys. The STM32F407ZGT board came. Filled the project to MCU. It does not work debug. Code Generator - CubEmx. The linker file is also from Cube. After starting the debug session (F8), the STARTUP_STM32F407xxx.s file opens in debugging and stepped out step by step until
bl   _libc_init_array

On one of his steps - 08000402..
080003FC    eors    r0, r6
080003FE    stmdb    sp!, {r2, r5, r6, sp, lr}
08000402    b.n    0x7ffff44

I get Cannot Access Memory AD Address 0x7FFFF30.

If I run Run and then stop - i get Hard Fault. I tried to start the same project in Cube IDE - everything is debugged and starts perfectly. But for obvious reasons I want to use EMBITZ. I Made a completely empty project CubEmx - flashing LED. In Cube IDE everything is ok. In EMBitz - the same - Cannot Access Memory AD Address 0x7FFFF30.
It looks like everything as if problems here -> or here -> I try adding -mthumb in settings. But it is no changed something. cortex-m4 is present.

.zip (Size: 2.44 KB / Downloads: 1) .
How to correctly adding neсessary swithes?
Sorry for My english. Can somebody help ?
The problem was not confirmed. The code works normally.

Attached Files
.zip (Size: 522.17 KB / Downloads: 3)
(03-08-2021, 02:05 PM)Mink Wrote: The problem was not confirmed. The code works normally.
O-o!!! many differrent settings in project. Your Project for Eblink really works. I use STlink.
Thanks for Help!
I will try my code.

Forum Jump:

Users browsing this thread: 1 Guest(s)