Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
EBlink not installing with EmBitz 2.50

First of all, thanks for great tool!!!
But I have to report a little hickup.

I'm working with STM32 micros and is using STLINK/V2.
I have the old patched EmBitz 1.11 on my PC (Windows 10).
I have also been using EmBitz 2.00 for quite some time.

Now I tried to install EmBitz 2.50. 
During installation, installer asked if I want to unistall the old EBlink. I don't understand why it would need to do that, and I don't remember what I selected. I have thought that the different EmBitz versions and their tools could co-exist, but maybe I'm wrong?
Anyhow, EmBitz 2.50 was installed with default everything.

BUT, now EBlink is not found by EmBitz 2.50 when trying to access the "Flash" menu in EmBitz. 
The folder "C:\Program Files (x86)\EmBitz\2.50\share\EBlink" exist, but it is empty.

I have tried multiple times, uninstalled both 2.00 and 2.50, then reinstalled 2.50. Always the same thing, EBlink folder is empty after installation is complete.
I took a closer look at the EBlink folder during installation, and the EBlinkInstaller.exe can be seen there, and it expands into some files and folders "packages", "scripts", "win32", etc. but when the installer is done, the whole folder is wiped clean.

Then I manually ran EBlinkInstaller.exe and installed it into that folder "C:\Program Files (x86)\EmBitz\2.50\share\EBlink", after all the installers where done.
Now EmBitz shows that EBlink is present, but when trying to connect to a target, it can't find "stm32-auto.script", even though I can see the script in "C:\Program Files (x86)\EmBitz\2.50\share\EBlink\scripts".

Interface USB# : 54FF6A066684565547522187
Interface type : STlink/V2
STlink connect : Under reset
Target voltage : 3.27V
Interface speed: 4000KHz
Target detected: Cortex-M4 (r0p1) with FPv4_SP
HW breakpoints : 6
HW watchpoints : 4
Fault unwind  : Active break (level 2)
Can't load device script: stm32-auto.script

Any ideas how I can get this to work?

I uninstalled 2.50 and installed 2.00. EBlink folder is NOT wiped clean in this installation, but that stm32-auto.script is not found, when connecting to a STM32. So problem has now migrated to EmBitz 2.00...
Yet another update:
I tried installing 2.50 again, and now specifying the installation folder "C:\Program Files (x86)\EBlink" for EBlink. Now the EBlink folder is not wiped clean when installation ends, but still that stm32-auto.script file can't be located by EmBitz, or is it EBlink that can't find it?

It's EBlink which can't find it.
Used environment variables by EBlink:

EB_SCRIPT_PATH      Will define the path where EBlink can find the scripts
EB_DEFAULT_PROBE    Will define the default interface [-I] option if not given on cli
EB_DEFAULT_SCRIPT  Will define the default script [-S] file if not given on cli

I don't have a clue why you are having these problems. If you know more, please share. Everything works here on my test laptop which I always use to test new installation packages.
Thanks for quick reply!

I don't have any additional info about why this have started to happen, I have not messed around with the internals of EmBitz at all.
But I suspect it has something todo with the installation of 2.00 vs 2.50 and the uninstall and reinstall of EBlink in different folders, and now somehow EmBitz is confused (on some level) where EBlink is located.
Where is the configuration for EmBitz where the location of EBlink is specified? When opening 2.50 after installation, it had inherited all IDE configurations from 2.00, so they seems to have some shared config.
I found config files in "C:\Users\<me>\AppData\Roaming\EmBitz\2.00" but don't find anything about EBlink there. Does the EBlink location come via Windows Registry?

Anyhow, about your suggestion:
In Settings / Environment... / Environment variables, I added the variable EB_SCRIPT_PATH with path to EBlink script folder.
The dialog complains that this variable is already set, but I guess it now overrides the old one.
And now EBlink can find the script file and it seems to work normally.

Many thanks!!!

Forum Jump:

Users browsing this thread: 1 Guest(s)