Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ST-Link V2-1 and Windows 10
#41
(20-09-2017, 06:08 AM)skibby Wrote: It's really a pity. On my other computer with Win 10 it showed the same error. As last try I uninstalled the ST-Link Utility and removed all "ST-Link Debug" entries in the device manager (hidden devices included). Then I reinstalled the new "ST-Link Utility" and now everything works including emBitz debugging :-) I think there was some garbage left from older drivers in the registry.

Hi, 
I did exactly the same. There was 8 hidden STLink devices, I removed all. Freshly installed the stsw009 drivers.
Unfortunately Embitz still not working with a Nucleo buil-in stlink v2.1.

Running the gdb from cmd window:

Quote:c:\Program Files (x86)\EmBitz\1.11\share\contrib>stlinkgdb
STLINK GDB Server (EmBitz Dec  8 2016 12:12:38)
Connect under reset is active.

2017-09-20T13:18:43 WARN E:\_stlink\stlink-master\src\stlink-usb.c: Couldn't open STlink/V2-1 probe at 001:005

c:\Program Files (x86)\EmBitz\1.11\share\contrib>


Embitz is working with an ebay v2 STLink.
Coocox is working with with the Nucleo v2.1 too.

The driver of the v2 and the v2.1 in the Device Manager:
http://www.kepfeltoltes.eu/view.php?file...linkv2.jpg
http://www.kepfeltoltes.eu/view.php?file...inkv21.jpg
[Image: [Image: view.php?filename=876stlinkv21.jpg]]

 [Image: view.php?filename=162stlinkv2.jpg]
Reply
#42
The issue for me was that when EmBitz creates a project and the wizard gets to the Debug Interface Options, if you change (or even look at the options for) the GDB selected interface, the default GDB Server is cleared and then EmBitz will require you to configure the GDB server (there is no way to get the defaults back even if you choose ST-link again).  

So once you've done that, if you want to use the STLinkGDB server included with EmBitz (a fine choice for STLink V2 and clones), you'll need to configure it manually after the project is created:

* Debug->Interfaces->GDB Server
   * Path: ${EMBITZ}\share\contrib
   * Executable: STLinkGDB.exe
   * Backoff time: 1000
Reply
#43
"there is no way to get the defaults back even if you choose ST-link again"

Yes, you can.
- Empty all the fields that must be replaced by default.
- Go into the stlink settings dialog
- Without changing anything click OK
- All empty fields are replaced by the defaults.
Reply
#44
For those who are still unable to debug using stlink v2-1 interface on the ST Nucleo embed enabled boards on Windows 10, there is a workaround...
I am using a WinXP SP3 virtual machine running in VirtualBox on my windows 10 system.
I am able to download debug firmware on my NUCLEO-F746ZG board without issue.

With the VM running in "Seamless" mode or even Windowed mode with the menus and status bars hidden it's almost indistinguishable from running natively.
Reply
#45
As I wrote above I run Win 7 in VM-Ware with working emBitz debugging.

But there is always a littledelay which is especially seen in singel-step-mode.

On a direkt Win7-Machine I can quickly step trough single lines.

In the virtual Win7-Machine on a Win10 host there are about 1-3 seconds of delay for every debugging action.

All VT-x (Hardware-virtualization etc.) of my I7-6700k seems to work.

Is this better in VirtualBox?
Reply
#46
https://github.com/Krakenw/Stlink-Bootloaders
Reply
#47
I'm running WIN 10 as my main OS so I have no need for WIN 7.
The VM I'm running is Win XP SP3 as it is a light OS compared to later windows.
There's no delay even when debugging but I'm running a Ryzen 7 with 16G RAM.
Reply
#48
(10-01-2018, 01:44 PM)vargham Wrote: https://github.com/Krakenw/Stlink-Bootloaders

So, you can upload the bootloader to your ST-Link. After that connect to the computer and start firmware upgrade from ST. It will ask you to select version to install. :-)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)