Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ST-Link V2-1 and Windows 10

Nucleo-F103RB connected:
c:\Program Files (x86)\EmBitz\1.11\share\contrib>stlinkgdb
STLINK GDB Server (EmBitz Dec 8 2016 12:12:38)
Connect under reset is active.

2017-04-06T13:00:50 WARN E:\_stlink\stlink-master\src\stlink-usb.c: Couldn't open STlink/V2-1 probe at 001:003

c:\Program Files (x86)\EmBitz\1.11\share\contrib>

Ebay STLink v2 connected to the same USB connector:

c:\Program Files (x86)\EmBitz\1.11\share\contrib>stlinkgdb
STLINK GDB Server (EmBitz Dec 8 2016 12:12:38)
Connect under reset is active.

Connected to STlink/V2 probe at 001:003
Chip ID is 00000410, Core ID is 1ba01477.
Target voltage: 3.22
Number of HW-breakpoints: 6
Listening at *:4242...

This is strange:
2017-04-06T13:00:50 WARN E:\_stlink\stlink-master\src\stlink-usb.c: Couldn't open STlink/V2-1 probe at 001:003
"E:\" ???
E: is the drive the STLink v2.1 makes for mbed application upload.
(04-02-2017, 07:55 PM)PDonchev Wrote: Hi,
Is there any working solution for using ST-Link V2-1 and EmBitz (under Windows 10)?
Yes, works pretty nice.

I'm using EmBitz with STM32F746G-DISC0 board. Already successfully ported the stock demonstration project
and I can download it with ST-Link Utility, but unfortunately debugging is not possible, because STLinkGDB can not connect with on-board ST-Link V2-1 device.

I had done this a couple of times before - connecting the board was never a Problem i had figured out.

Only workaround for me was to break connection between on-board ST-Link and STM32F746 and use external ST-LinkV2. In this way I can debug successfully.

You should look  into this Forum to a Archive of released Nucleo 746g Project template, where the ST-Link Debugger is preconfigured right - you just Need to Change the detailed mpu type.
Yoiu will be get in other Problems around the F746 - there are some issues about source Level Debugging and breaking at ISR's, even none breakpoint was placed into them. This is  a chip-bug in r0p1 of the F756 and there are just one known Workaround available released for free by segger. This simple tool replace the st-link Firmware by seggers modified j-link Firmware, where the bug will not be an  issue . The side effect of this debugging Firmware Change is, that this Speeds up the upload Debugging more than two times.
You can replace the j-link Firmware  by the original with the same tool, if this is required one time. I had done this several times and this works  pretty stable. 

Windows 10 was never ever a problem by emBitz or the gcc toolchain.

"Windows 10 was never ever a problem by emBitz or the gcc toolchain."

=> aha, interesting, cause...

I have 4 pieces of STM32F469Disco-Boards here.

Only one is working directly at my I7-6700-Asus-MB-PC with WIN10/64  (even via a USB 3.0-Hub)

The second only works on the same computer within a virual W10/64-machine

...and the third and fourth doesn't work neither.

But all four work in a virtual Win7/32-machine on this computer.

Connecting via USB 2.0 or 3.0 doesn't change anything

On other computers with WIN10 (ex. one tablet with USB2.0-only) also some, but different boards work - and vice versa...

I also tried all available firmwares from 2014 to 2017 and drivers (actual and older)

That all doesn't change anything!!

The only thing I can reach with Zadig is, that even ST-Link-Utility doesn't recognize the Board any more.

I had simmilar problems with some Nucleo-Boards. But there you can finally connect a cheap China-Debugger with a few wires, but on the 469-Disco the lines between the Debugger-IC and the 469 are not accessible.

There seems to be no logic in this "equation" - execept one constant: WIN10  Huh

 "Windows 10 was never ever a problem by emBitz or the gcc toolchain."

=> I don't think that this is true, sorry

Best regards


I think this problem is important. The Nucleo board is popular and inexpensive. Embitz looses many potential users, if the first test fails on Nucleo.

The lack of import function is serious problem too. ST provides many code samples for 3-4 IDE, most people is about to try them. While not too hard to convert manually, it's frustrating for a beginner.
I fully agree the statement of VOROSJ

I like emBitz very much - small installation, fast, helpfull debugging features, easy importing of 3rd party projects (if you once got it) - everything I need but not to much. Heart

I don't like this eclipse-based stuff (CooCox, AC6, Atollic) - delays at startup and debugging, generally slow, lager installation, no clear structure (imho), not a very clear concept at all... Confused

I tried Visual-GDB - not a bad alternative to emBitz, but lot's of gigabytes installation for nearly the same functionality. Shy

emBitz has very much pros on it's side, but if I only can use it within a virtual WIN-7-Machine they are mostly gone. Sad Sad

Hearing from an emBitz-update solving this problem woul be very great news!   Cool Cool Cool Cool Cool
Same problem here. (No connection, no USB device, reset during debugging, etc.) The root cause is the V2-1 with mass storage function.
Details here:
Standalone ST-Link V2 (even clone one) works fine. So I downloaded an old ST-Link V2 firmware from a russian site, I soldered wires to SW_CLK and SW_DIO pins of debugger, uploaded firmware. ST-Link utility recogized it, and updated the firmware to the newest V2 (not V2-1) firmware. I lost mass storage and virtual serial, but I won perfect connection and reliable debugging.
Hello Vargham,

sounds interesting.

Do You have a link to this V2-Firmware?

Is there no way to bring it this Firmware to the board without soldering SWD-Wires?
You should search for
I soldered the SWD wires.

Another option: Change firmware to J-Link. It is official, see here:
I have been using ST-Link for many years. There have been many obstacles, but at the end, those have been resolved. The current issue is not caused by EmBitz, but could be resolved with the support from EmBitz.

My eBay/Aliexpress St-Link V2 dongles have been very low cost and working reliably. Some weeks ago, I got a new F407 board and checked it. Everything was working perfectly. Now, when returned to the same board with the same dongles, things are not working. Even St-Link Utility is failing to connect to the board. I can get the Utility to do the connection if I am doing a well-synchronized manual board reset at the same time. This works with the utility but doesn't work with EmBitz.

I have all the latest binaries from ST. My guess is that the latest "huge" upgrade from MS for Win10 is causing this. The normal upgrades have been fast; perhaps 2-5 minutes. This last one took 20-30 minutes.
Cheers, Ollie
I think it's a combination of STmicro "enhancements" and windows 10 modifications. A lot of sh*t started when ST starting supporting Mbed with those composite USB functions as mass-storage.

The strange thing is that users are reporting that other, non vendor, tools (like openOCD) don't have any issues with win10. But I can't figure out how this is done nor do I get any feedback of those reporting users how they did it.

It 's really becoming a pain in the ass because I have to play chess on different boards. And that is just one vendor.

E.g. I bought a new F429-DISC1 board, I even can't get that board working in windows 7 because it wont install any drivers. Manual override gives low voltage error's ???!??

Forum Jump:

Users browsing this thread: 1 Guest(s)