Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The .weak bug in gcc
#2
EmBitz after 2.30 is using 9.3.1 and your "bug" reference is about 7.2.1

If I use LTO I always make this workable by changing the build priority of the particular files so that they will be linked before the .weak functions are pulled in.

Tip: This workaround can also be found on the internet where users are discussing these problems.
Reply


Messages In This Thread
The .weak bug in gcc - by PDonchev - 19-04-2022, 09:17 PM
RE: The .weak bug in gcc - by embitz - 20-04-2022, 09:35 AM
RE: The .weak bug in gcc - by PDonchev - 20-04-2022, 07:41 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)