Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 978
» Latest member: barabek
» Forum threads: 857
» Forum posts: 5,090

Full Statistics

Latest Threads
Kinetis MK66 & SVD
Forum: SVD (System view) files
Last Post: Workalot
Yesterday, 10:05 AM
» Replies: 0
» Views: 23
Download/Debugging Silabs...
Forum: Debug interface scripting
Last Post: Polarisru
10-12-2018, 01:38 PM
» Replies: 4
» Views: 1,149
Burning flash and debuggi...
Forum: Debug interface scripting
Last Post: Polarisru
10-12-2018, 01:33 PM
» Replies: 0
» Views: 36
Embitz with GCC-ARM
Forum: ArmGCC - EmBlocks
Last Post: Tony201800
30-11-2018, 12:01 AM
» Replies: 0
» Views: 158
emBitz, MK66, Debugger an...
Forum: EmBitz IDE
Last Post: Workalot
27-11-2018, 10:40 AM
» Replies: 1
» Views: 190
EBLINK: STM32L496ZG not s...
Forum: Debug interface scripting
Last Post: vargham
22-11-2018, 09:36 AM
» Replies: 1
» Views: 385
warning: implicit declara...
Forum: ArmGCC - EmBlocks
Last Post: bbennett
17-11-2018, 09:02 PM
» Replies: 1
» Views: 191
Print diagnostic messages...
Forum: EmBitz IDE
Last Post: AVI-crak
13-11-2018, 03:27 PM
» Replies: 0
» Views: 152
The case for CAN
Forum: General
Last Post: DD4DA
02-11-2018, 11:09 AM
» Replies: 3
» Views: 667
Does Embitz support Emwin...
Forum: EmBitz IDE
Last Post: ray911
25-10-2018, 06:03 AM
» Replies: 2
» Views: 485

 
  Still confused about preprocessor coloring
Posted by: BobAGI - 19-06-2012, 06:24 AM - Forum: EmBitz IDE - Replies (4)

I'm sorry, but I still cannot get it to work...
I decided to drop all artifacts from my earlier configurations by closing EmBlocks, then renaming the configuration folder in AppData and then start anew. This recreated a new instance for 1.30 with default files and of course my own coloring scheme gone.
Then I modified the coloring to suit me and in the configuration dialog it looked OK.
But in the real code edit window the preprocessor stuff is completely screwed up, for example:
#ifdef SOMEID
code of some kind
#else
code of some other kind
#endif

BOTH the first and second section are colored in active style, so the syntax highlight for inactive code is NOT used.
Clearly no matter how the SOMEID is defined (locally, in a local include file or by compiler) the #else must separate two different cases of highlight????
I have used the Microchip boot loader code as an example:
   
For this example the configuration is like this:
   

If I right click the identifier USE_AUTOBAUD EmBlocks jumps directly to the corresponding config.h file and marks the identifier. Here can be viewed a very clear example of the problem because the define is followed by a conditional #ifdef, which misses the highlight even though the define was done only a few lines before:
   

Have I completely lost track of the necessary steps? I have replaced the emblocks.dll file with the corrected beta version so it should be the very latest code used.

Print this item

  Keeping workspace for later re-open?
Posted by: BobAGI - 18-06-2012, 11:31 AM - Forum: EmBitz IDE - Replies (4)

I had opened my application project in EmBlocks and then the corresponding boot loader, so both projects were listed in the workspace.
But then when I closed EmBlocks and later restarted I did not get the option anymore of opening my workspace, only the individual projects. Cry
Is there not a need for keeping a workspace file of sorts so that one can open the complete thing the next time????

Print this item

  [solved]Beta 1.30: Graying out code that is not disabled...
Posted by: BobAGI - 13-06-2012, 11:04 PM - Forum: EmBitz IDE - Replies (8)

There is a problem with the syntax highlighting....
The preprocessor commands that were colored purple with 1.20 are now black (#if #else and so on).
If I go into the syntax highlighting part of the editor settings and select the Preprocessor item I can set it to anything, but the color will not change. It does not change in the example pane and not in my code.

Furthermore I have a section of code in my configuration file init.h which is CPU specific so I have adopted the Microchip technique of using the processor name defines:

Code:
#if defined (__PIC24FJ256GB206__)
    // Place your PIC24FJ256GB206 specific code here
    ....
#endif
My problem is that EmBlocks 1.30 grays out the code in the section even though MPLAB 8.80 correctly does not.
The compiler works fine but the editor not, it does not show the situation correctly.
I have tried using #ifdef (name) as well but this does not change anything with 1.30

Print this item

  Beta 1.30: How do I set colors for separators?
Posted by: BobAGI - 13-06-2012, 08:03 PM - Forum: EmBitz IDE - Replies (3)

Now after updating to beta 1.3 I have noticed that the coloring is a bit strange still....
(Note that I have copied my configuration files from 1.2 into 1.3)

1) All of my braces { and } have changed to red color
2) All operators like >= == = >> & etc are also red
3) The void keyword for functions is now shown bold and in a kind of yellowish brown

And I cannot find where I can change these items.
Not mentioned in the list of optional things to set color for.

Notice that the only items I have set to be red are string and character, but still all these separators and operators are red.

By the way, I tried starting Beta 1.2 as well to be able to compare side by side but it would not start....
The focus just jumps to the already started 1.3.
So I closed 1.3 and started 1.2 and here I have:
- Black braces
- black operators
- void, if, else etc are shown dark blue bold as I want

And there are a whole lot more keywords in the syntax highlighting selection box too.

Print this item

  [solved]Preprocessor evaluation doesn't work on token level
Posted by: mtesmer - 13-06-2012, 10:15 AM - Forum: EmBitz IDE - Replies (12)

Hello,

Thank You for a quick release, but unfortunately new preprocessor changes not working for my #if, #elif cases. Basically in my program #elif directive always living code greyed, no mater what conditions I set. Same appear for #if, but case is opposite - code is never greyed. It might due to my code/settings issues. I'm open for any suggestions.

I attached screen with few code samples explain problem more clearly. You can also see some minor quirk where green color overflow to #if,#elif condition (seems that brackets are not recognize properly)



Attached Files Thumbnail(s)
   
Print this item

  #define coloring suggestion
Posted by: mtesmer - 08-06-2012, 11:28 AM - Forum: EmBitz IDE - Replies (1)

Hello,

At the moment preprocessor have fixed colour for whole syntax. Is it possible to have an independent colour assignment for each component (ie. like Mchip did in their compiler)?

Like:
#define SJA1000_RX_IDLE_COUNTER 0x40
instead of:
#define SJA1000_RX_IDLE_COUNTER 0x40

Rgs,
Marcin

Print this item

  [solved]Symbol browsing (function list) incomplete
Posted by: BobAGI - 08-06-2012, 09:19 AM - Forum: EmBitz IDE - Replies (7)

This concerns a Microchip PIC24FJ256GB206 project. I use the C30 compiler.

When I open my interrupts.c file and activate the Symbols tab in the left pane, then the "Global functions" only show my own initialization functions, which I have placed in this file.
But none of he interrupt functions are visible. They are not even shown in the extended function dropdown that I have enabled according to advice in the Microchip forum (can't remember how anymore).

The functions that are shown are:

__attribute__((interrupt,no_auto_psv)): void
InitPpsInt2(void):void
Start_Timer1(int frequency): void
Start_Timer23(void): void
Start_Timer45(void): void

These are missing:

__attribute__((interrupt,no_auto_psv)) _INT1Interrupt(void): void
__attribute__((interrupt,no_auto_psv)) _INT2Interrupt(void): void
__attribute__ ((interrupt,no_auto_psv)) _T1Interrupt (void): void
__attribute__ ((interrupt,no_auto_psv)) _T3Interrupt (void): void
__attribute__ ((interrupt,no_auto_psv)) _T5Interrupt (void): void
__attribute__ ((interrupt,no_auto_psv)) _U1RXInterrupt(void): void
__attribute__ ((interrupt,no_auto_psv)) _U2RXInterrupt(void): void
__attribute__ ((interrupt,no_auto_psv)) _U3RXInterrupt(void): void
__attribute__ ((interrupt,no_auto_psv)) _U4RXInterrupt(void): void
__attribute__ ((interrupt,no_auto_psv)) _U1TXInterrupt(void): void
__attribute__ ((interrupt,no_auto_psv)) _U2TXInterrupt(void): void
__attribute__ ((interrupt,no_auto_psv)) _MI2C2Interrupt(void): void
__attribute__ ((interrupt,no_auto_psv)) _OC2Interrupt(void): void

But they should be shown as:
_INT1Interrupt(void): void
_INT2Interrupt(void): void
_MI2C2Interrupt(void): void
_OC2Interrupt(void): void
_T1Interrupt (void): void
_T3Interrupt (void): void
_T5Interrupt (void): void
_U1RXInterrupt(void): void
_U2RXInterrupt(void): void
_U3RXInterrupt(void): void
_U4RXInterrupt(void): void
_U1TXInterrupt(void): void
_U2TXInterrupt(void): void

(No need to display the attribute part in the list.....)

It seems like the IDE function parsing chokes on the first occurrence of an interrupt service routine when the attribute part confuses the parsing totally. It looks like the parser thinks the function name is __attribute__ :?:

Bo B

Print this item

  [solved] Greying out inactive code does not work
Posted by: BobAGI - 06-06-2012, 08:23 AM - Forum: EmBitz IDE - Replies (7)

It might be a configuration issue, but I have not been able to figure this out so I ask here instead....
It affects both Beta 1.00 and Beta 1.20.
No matter how I set the check-box "Interpret #if, #else, #endif to grey out inactive preprocessor -code" on the Editor settings General tab the code in my main.c file surrounded by #if defined does not change color to grey.
I have defined the symbol or commented out the definition and it makes no difference.
Example code:
In a header file:

Code:
//#define _DEBUGMSG_
In main.c:
Code:
    #if defined _DEBUGMSG_
        ul2a(stmp, configuration.timer23count, 10);
        putstr_com(&com4,stmp,0);
        putchar_com(&com4,0x0D);
        putchar_com(&com4,0x0A);
        putstr_com(&com1,"Starting test com1\n",0);    //Debug message
        putstr_com(&com2,"Starting test com2\n",0);    //Debug message
        putstr_com(&com3,"Starting test com3\n",0);    //Debug message
        putstr_com(&com4,"Starting test com4\n",0);    //Debug message
        putstr_combb(&com5,"U*",0);    //Debug message
    #endif
I expected the lines between #if and #endif to be greyed out unless the comment is removed in front of the #define in the header file, but syntax highlighting is visible all the time...

EmBlocks is able to find the definition of the identifier when I right click in main.c provided it is not commented out, otherwise it does not find it. So it really knows the whereabouts and state of the identifier.

Probably I have made a simple configuration error after first installing Beta 1.20 with all plugins enabled and then modifying the syntax highlighting to suit my taste of colors.
But I cannot for the life of me understand what this could be.
--
Bo B

Print this item

  Suggestions future releases
Posted by: EmBitz - 29-11-2011, 02:11 PM - Forum: EmBitz IDE - Replies (133)

For the next releases:
- Support ARM SVD for debugger peripheral awareness (XML description of the device internals)
- FreeRTOS viewer debugger plugin
- Options on file level
- Split local and watch view (are now on the same pane).
- Graphical linker script editor plugin for GNU.


Future releases:
- A "Rebuild and run to current line" as debugger option to make corrections "on-the-fly".
If you are running in the targets Ram then this can be very fast.
- PIC32 GDB proxy server (beating a dead horse, Microchip isn't cooperative on this one)



Any user suggestions are very welcome.

Print this item